summaryrefslogtreecommitdiff
path: root/dev-libs/libsigsegv/libsigsegv-2.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsigsegv/libsigsegv-2.11.ebuild')
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.11.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/libsigsegv-2.11.ebuild b/dev-libs/libsigsegv/libsigsegv-2.11.ebuild
new file mode 100644
index 000000000000..5ab74d80c3a5
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library for handling page faults in user mode"
+HOMEPAGE="https://www.gnu.org/software/libsigsegv/"
+SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_configure () {
+ econf --enable-shared || die "Configure phase failed"
+}
+
+src_test () {
+ if [[ ${FEATURES} = *sandbox* ]] ; then
+ # skip tests as they will fail
+ ewarn "Skipped tests. Please disable sandbox to run tests."
+ return 0
+ fi
+ emake check || die "Tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog* NEWS PORTING README
+}