summaryrefslogtreecommitdiff
path: root/dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild b/dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild
new file mode 100644
index 000000000000..8b7be2b0ab39
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake-utils_src_test
+}