summaryrefslogtreecommitdiff
path: root/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild')
-rw-r--r--dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild b/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
index dd429b891a4f..9e2c81a16649 100644
--- a/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
+++ b/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
@@ -58,6 +58,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with mysql)
$(use_with postgres postgresql)
$(use_with sqlite sqlite3)
@@ -65,13 +66,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"