summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-3.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-3.8.0.ebuild')
-rw-r--r--dev-libs/libnl/libnl-3.8.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-libs/libnl/libnl-3.8.0.ebuild b/dev-libs/libnl/libnl-3.8.0.ebuild
index c72e4b01c347..fc8c3de4664e 100644
--- a/dev-libs/libnl/libnl-3.8.0.ebuild
+++ b/dev-libs/libnl/libnl-3.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${LIBNL_P}"
fi
@@ -30,7 +30,9 @@ fi
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
IUSE="+debug python test utils"
-RESTRICT="!test? ( test )"
+# Tests fail w/ sandboxes
+# https://github.com/thom311/libnl/issues/361
+RESTRICT="!test? ( test ) test"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"