summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-1.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-1.1.9999.ebuild')
-rw-r--r--dev-libs/libnl/libnl-1.1.9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/libnl/libnl-1.1.9999.ebuild b/dev-libs/libnl/libnl-1.1.9999.ebuild
index 30fa4a923c0f..14a4835802c4 100644
--- a/dev-libs/libnl/libnl-1.1.9999.ebuild
+++ b/dev-libs/libnl/libnl-1.1.9999.ebuild
@@ -2,18 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 multilib toolchain-funcs
+
+inherit git-r3 toolchain-funcs
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/"
EGIT_REPO_URI="https://github.com/tgraf/libnl-1.1-stable"
+
LICENSE="LGPL-2.1"
SLOT="1.1"
-KEYWORDS=""
IUSE="doc static-libs"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
+
DOCS=( ChangeLog )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
"${FILESDIR}"/${PN}-1.1-flags.patch
@@ -30,18 +33,18 @@ src_prepare() {
-e 's|-g ||g' \
Makefile.opts.in || die
- if ! use static-libs; then
+ if ! use static-libs ; then
sed -i lib/Makefile -e '/OUT_AR/d' || die
fi
- rm -f lib/libnl.a
+ rm -f lib/libnl.a || die
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
emake gendoc
fi
}
@@ -50,7 +53,7 @@ src_install() {
default
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
docinto html
dodoc -r html/*
fi