summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-1.1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-1.1.4-r1.ebuild')
-rw-r--r--dev-libs/libnl/libnl-1.1.4-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-libs/libnl/libnl-1.1.4-r1.ebuild b/dev-libs/libnl/libnl-1.1.4-r1.ebuild
index 40141bb55b71..8f3ad2437d6f 100644
--- a/dev-libs/libnl/libnl-1.1.4-r1.ebuild
+++ b/dev-libs/libnl/libnl-1.1.4-r1.ebuild
@@ -2,18 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/"
SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="1.1"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc static-libs"
DEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
"${FILESDIR}"/${PN}-1.1-flags.patch
@@ -34,14 +37,14 @@ src_prepare() {
sed -i lib/Makefile -e '/OUT_AR/d' || die
fi
- rm -f lib/libnl.a
+ rm -f lib/libnl.a || die
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
emake gendoc
fi
}
@@ -50,7 +53,8 @@ src_install() {
default
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
+
docinto html
dodoc -r html/*
fi