summaryrefslogtreecommitdiff
path: root/dev-libs/libnest2d/libnest2d-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnest2d/libnest2d-0.4.ebuild')
-rw-r--r--dev-libs/libnest2d/libnest2d-0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libnest2d/libnest2d-0.4.ebuild b/dev-libs/libnest2d/libnest2d-0.4.ebuild
new file mode 100644
index 000000000000..c9896b772210
--- /dev/null
+++ b/dev-libs/libnest2d/libnest2d-0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Library and framework for the 2D bin packaging problem"
+HOMEPAGE="https://github.com/tamasmeszaros/libnest2d"
+SRC_URI="https://github.com/tamasmeszaros/libnest2d/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="examples static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost
+ dev-libs/clipper
+ sci-libs/nlopt
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/catch-2.9.1 )
+ "
+
+PATCHES=( "${FILESDIR}"/${P}-add-disallowed-areas.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DLIBNEST2D_BUILD_EXAMPLES=$(usex examples)
+ -DLIBNEST2D_HEADER_ONLY=$(usex static-libs OFF ON)
+ -DLIBNEST2D_BUILD_UNITTESTS=$(usex test)
+ )
+ cmake_src_configure
+}