summaryrefslogtreecommitdiff
path: root/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
index 3f3d5b686185..f376df81912c 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Provides an uniform interface to access several encryption algorithms"
HOMEPAGE="https://mcrypt.sourceforge.net"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha ~amd64 arm arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
DOCS=(
AUTHORS NEWS README THANKS TODO ChangeLog
@@ -39,6 +39,14 @@ src_prepare() {
eautoreconf # update stale autotools
}
+src_configure() {
+ # LTO type mismatch (bug #924867)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die