summaryrefslogtreecommitdiff
path: root/dev-libs/libmcfp/libmcfp-1.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmcfp/libmcfp-1.2.2.ebuild')
-rw-r--r--dev-libs/libmcfp/libmcfp-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libmcfp/libmcfp-1.2.2.ebuild b/dev-libs/libmcfp/libmcfp-1.2.2.ebuild
new file mode 100644
index 000000000000..8b268787ec13
--- /dev/null
+++ b/dev-libs/libmcfp/libmcfp-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A library that can collect configuration options from command line arguments"
+HOMEPAGE="https://github.com/mhekkel/libmcfp"
+SRC_URI="https://github.com/mhekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}