summaryrefslogtreecommitdiff
path: root/dev-libs/libmateweather/libmateweather-1.24.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmateweather/libmateweather-1.24.1.ebuild')
-rw-r--r--dev-libs/libmateweather/libmateweather-1.24.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/libmateweather-1.24.1.ebuild b/dev-libs/libmateweather/libmateweather-1.24.1.ebuild
new file mode 100644
index 000000000000..a5ee3530e693
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.24.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit eapi7-ver mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}