summaryrefslogtreecommitdiff
path: root/dev-libs/libixion/libixion-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion/libixion-9999.ebuild')
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 274322f24718..ec4bffd84edf 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/2.1"
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
else
- MDDS_SLOT="1/2.0"
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.18" # based on SONAME of libixion.so
+SLOT="0/0.20" # based on SONAME of libixion.so
IUSE="debug python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"