summaryrefslogtreecommitdiff
path: root/dev-libs/libixion/libixion-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion/libixion-9999.ebuild')
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index f52b1d4a22b5..28084226f1e7 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -9,23 +9,25 @@ inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
+ MDDS_SLOT="1/9999"
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
else
+ MDDS_SLOT="1/1.5"
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.15" # based on SONAME of libixion.so
+SLOT="0/0.16" # based on SONAME of libixion.so
IUSE="debug python static-libs +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/boost:=
- >=dev-util/mdds-1.5.0:1=
+ dev-util/mdds:${MDDS_SLOT}
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
@@ -38,15 +40,17 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable python) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable python)
+ $(use_enable static-libs static)
$(use_enable threads)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {