summaryrefslogtreecommitdiff
path: root/dev-libs/libhome
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libhome')
-rw-r--r--dev-libs/libhome/Manifest5
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-Makefile.patch59
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch12
-rw-r--r--dev-libs/libhome/libhome-0.10.2-r2.ebuild56
-rw-r--r--dev-libs/libhome/metadata.xml8
5 files changed, 140 insertions, 0 deletions
diff --git a/dev-libs/libhome/Manifest b/dev-libs/libhome/Manifest
new file mode 100644
index 000000000000..76fbfcf685cf
--- /dev/null
+++ b/dev-libs/libhome/Manifest
@@ -0,0 +1,5 @@
+AUX libhome-0.10.2-Makefile.patch 2595 BLAKE2B 1ea80fd25b2f0d15cad374e132c37b1cdb26167cae9a2e1bdcc532230b1193057e10577d5a019c21bfed1b6aabdc41452a52397a7268ab0cfe4ba480040bc63e SHA512 c5594a56637570d76225a72a490a6e2a1dc1525c2a539e2a8bba9580364b449868e4f66bdddc9662e5a600658142e582c426fbceb4f68335b646a7cd1b7af692
+AUX libhome-0.10.2-ldap_deprecated.patch 436 BLAKE2B dac750c9499423992a236c1c1370c4e2b9b219b546ac9b87c1ac9aba7277592f52dd175e568226588315bab6110fc48e11d859193b1b454734e10c6ff9f3cfc0 SHA512 9837639846acb2e89c92e0b821faf40d9ee82af9f6837ea69b3d435da6433c6095b45dbf09178de5d361993405141bf9ac7b91e8f6a0bda65d038f80c6897ae7
+DIST libhome-0.10.2.tar.gz 286453 BLAKE2B bb2356fef6358b849896c665760174decbf5f83f70380c855c519c6a8cde37e053af70962f7552ffdd581b1af559bbc4a74d7d8ccedad39fa4a178ded394436c SHA512 9f144b6aeb8e01f5ca2f8f90c5289d4449895e2eddbfd2d8d9b1828bb203fd8f68c224c0f068ffabfa5ee1514f9b756cb2499f862418d793eb8d06ae960447a9
+EBUILD libhome-0.10.2-r2.ebuild 1198 BLAKE2B 577f78ce8270b6bd79db641ac1feef295e48bab090a358342dfaafb3bb242c58fe151c8be177b77cba84fec153144af52fc06bd4d60b6380914d5d3fdeb767b3 SHA512 e454ca4b1359063b151a91c53ad149b5e51a4acde59208a8b3cb688cc94c2f6785224dcfd6921801d75ba0a616d4373dd1f35c7afe6981c75abb67afde3c4124
+MISC metadata.xml 240 BLAKE2B 2e3833d1ad4ea9595d87b465cc7ddc1c7265e408573c1cccd947df928faa1db495ba24ad4417ba6dc46a8ddbe36876775dfda70309472348ac6273554b8e62da SHA512 b81e5b5547e3dc86326d624d771f3c7a55f6b85989c0de3827fd9df823f7fef49d66e6ba814d1ee6ee0e02bbc9705f00aa74ea6d247abe3db5cf3a57e4171455
diff --git a/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
new file mode 100644
index 000000000000..371335b0bec8
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
@@ -0,0 +1,59 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -61,7 +61,7 @@
+ LIBTOOL=./libtool
+
+ COMPILE=${LIBTOOL} --mode=compile ${CC} ${CPPFLAGS} ${CFLAGS}
+-LINK=${LIBTOOL} --mode=link ${CC} ${CFLAGS}
++LINK=${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${LDFLAGS}
+
+
+ hparam.o: version.h
+@@ -114,27 +114,32 @@
+ install:: install-man install-lib
+
+ install-man:: home.conf.5
+- ${INSTALL_DATA} home.conf.5 ${mandir}/man5/
+-@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 ${mandir}/man8/
++ ${INSTALL} -d $(DESTDIR)${mandir}/man5
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${mandir}/man8
++ ${INSTALL_DATA} home.conf.5 $(DESTDIR)${mandir}/man5/
++@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 $(DESTDIR)${mandir}/man8/
+
+ install-lib:: all
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la ${libdir}/
++ ${INSTALL} -d $(DESTDIR)${libdir}
++ ${INSTALL} -d $(DESTDIR)${bindir}
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${sbindir}
++ ${INSTALL} -d $(DESTDIR)${includedir}/home
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la $(DESTDIR)${libdir}/
+ test "@PRELOAD_LIB@" = "" || \
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ ${libdir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger ${bindir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su ${bindir}/
+- -mkdir -p ${includedir}/home
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/pwd.h
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/
+- ${INSTALL_DATA} hparam.h ${includedir}/home/
+- ${INSTALL_DATA} home_version.h ${includedir}/home/
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ $(DESTDIR)${libdir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger $(DESTDIR)${bindir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su $(DESTDIR)${bindir}/
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/pwd.h
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D hparam.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D home_version.h $(DESTDIR)${includedir}/home/
+ chmod +x libhome.sh
+- ${INSTALL_SCRIPT} libhome.sh ${bindir}/
+-@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy ${sbindir}/
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++ ${INSTALL_SCRIPT} -D libhome.sh $(DESTDIR)${bindir}/
++@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy $(DESTDIR)${sbindir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ install-nss:: nss
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ compat:
+ -mkdir compat
diff --git a/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
new file mode 100644
index 000000000000..a96645176c13
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
@@ -0,0 +1,12 @@
+Index: libhome-0.10.2/hldap.c
+===================================================================
+--- libhome-0.10.2.orig/hldap.c
++++ libhome-0.10.2/hldap.c
+@@ -27,6 +27,7 @@ static char const rcsid[] UNUSED =
+ "$Id: libhome-0.10.2-ldap_deprecated.patch,v 1.1 2009/07/05 19:25:41 hollow Exp $";
+
+ #define passwd system_passwd
++#define LDAP_DEPRECATED 1
+ #include <lber.h> /* for openldap 1.x */
+ #include <ldap.h>
+ #include <errno.h>
diff --git a/dev-libs/libhome/libhome-0.10.2-r2.ebuild b/dev-libs/libhome/libhome-0.10.2-r2.ebuild
new file mode 100644
index 000000000000..b94cfd3c8377
--- /dev/null
+++ b/dev-libs/libhome/libhome-0.10.2-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools db-use
+
+DESCRIPTION="libhome is a library providing a getpwnam() emulation"
+HOMEPAGE="http://pll.sourceforge.net"
+SRC_URI="mirror://sourceforge/pll/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb ldap mysql pam postgres static-libs"
+
+DEPEND="berkdb? ( >=sys-libs/db-4 )
+ ldap? ( net-nds/openldap )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql[server] )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.2-Makefile.patch
+ "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
+)
+
+src_prepare() {
+ rm -f aclocal.m4
+
+ default
+
+ # bug 225579
+ sed -i -e 's:\<VERSION\>:__PKG_VERSION:' configure.in
+
+ sed -i -e '/AC_SEARCH_LIBS.*db4/s: db-4.* db4:'$(db_libname)':' \
+ configure.in
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-db3 \
+ $(use_with berkdb db4 $(db_includedir)) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with postgres pgsql) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${D}" -name '*.la' -delete
+}
diff --git a/dev-libs/libhome/metadata.xml b/dev-libs/libhome/metadata.xml
new file mode 100644
index 000000000000..77f70a1e61a5
--- /dev/null
+++ b/dev-libs/libhome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">pll</remote-id>
+ </upstream>
+</pkgmetadata>