summaryrefslogtreecommitdiff
path: root/dev-libs/libev/libev-4.33.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libev/libev-4.33.ebuild')
-rw-r--r--dev-libs/libev/libev-4.33.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/libev/libev-4.33.ebuild b/dev-libs/libev/libev-4.33.ebuild
index 127618dc6d37..b8ffdb37c3da 100644
--- a/dev-libs/libev/libev-4.33.ebuild
+++ b/dev-libs/libev/libev-4.33.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="A high-performance event loop/event model with lots of feature"
HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
@@ -27,6 +27,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \