summaryrefslogtreecommitdiff
path: root/dev-libs/libestr/libestr-0.1.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libestr/libestr-0.1.11.ebuild')
-rw-r--r--dev-libs/libestr/libestr-0.1.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libestr/libestr-0.1.11.ebuild b/dev-libs/libestr/libestr-0.1.11.ebuild
new file mode 100644
index 000000000000..719c5dac2533
--- /dev/null
+++ b/dev-libs/libestr/libestr-0.1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Library for some string essentials"
+HOMEPAGE="http://libestr.adiscon.com/"
+SRC_URI="http://libestr.adiscon.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="debug static-libs test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable test testbench)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}