summaryrefslogtreecommitdiff
path: root/dev-libs/libebml/libebml-1.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libebml/libebml-1.4.2.ebuild')
-rw-r--r--dev-libs/libebml/libebml-1.4.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-1.4.2.ebuild b/dev-libs/libebml/libebml-1.4.2.ebuild
new file mode 100644
index 000000000000..be4140b75697
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.4.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5" # subslot = soname major version
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=YES
+ )
+
+ cmake_src_configure
+}