summaryrefslogtreecommitdiff
path: root/dev-libs/libdnet/libdnet-1.16.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdnet/libdnet-1.16.4.ebuild')
-rw-r--r--dev-libs/libdnet/libdnet-1.16.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/libdnet/libdnet-1.16.4.ebuild b/dev-libs/libdnet/libdnet-1.16.4.ebuild
index 63ed423fc1db..08f0bd6dfacb 100644
--- a/dev-libs/libdnet/libdnet-1.16.4.ebuild
+++ b/dev-libs/libdnet/libdnet-1.16.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ S="${WORKDIR}/${PN}-${P}"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv sparc x86"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
IUSE="python test"
RESTRICT="!test? ( test )"
@@ -70,6 +70,12 @@ src_compile() {
fi
}
+src_test() {
+ # https://bugs.gentoo.org/778797#c4
+ # check_ip needs privileges and check_fw can't work on Linux
+ emake check XFAIL_TESTS="check_fw check_ip"
+}
+
src_install() {
default