summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd/libbsd-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbsd/libbsd-0.8.3.ebuild')
-rw-r--r--dev-libs/libbsd/libbsd-0.8.3.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-libs/libbsd/libbsd-0.8.3.ebuild b/dev-libs/libbsd/libbsd-0.8.3.ebuild
deleted file mode 100644
index 920b765cd2b6..000000000000
--- a/dev-libs/libbsd/libbsd-0.8.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils multilib-minimal
-
-DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
-HOMEPAGE="https://libbsd.freedesktop.org/wiki/"
-SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
-
-LICENSE="BSD BSD-2 BSD-4 ISC"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-DEPEND=">=sys-kernel/linux-headers-3.17"
-RDEPEND=""
-
-pkg_setup() {
- local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
- local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
- if ! has_version ${CATEGORY}/${PN}; then
- if [[ -e ${f} ]]; then
- eerror "${m}"
- die "${m}"
- fi
- fi
-}
-
-multilib_src_configure() {
- # The build system will install libbsd-ctor.a despite of USE="-static-libs"
- # which is correct, see:
- # https://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files
-}