summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbsd/libbsd-0.11.7-r2.ebuild')
-rw-r--r--dev-libs/libbsd/libbsd-0.11.7-r2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
index 0fcfb6bd563b..2a0049ad643a 100644
--- a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
+++ b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/guillemjover.asc
-inherit multilib multilib-minimal verify-sig
+inherit autotools multilib multilib-minimal verify-sig
DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
@@ -22,6 +22,17 @@ DEPEND="${RDEPEND}
"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-guillemjover )"
+PATCHES=(
+ "${FILESDIR}/libbsd-build-Fix-version-script-linker-support-detection.patch"
+)
+
+src_prepare() {
+ default
+
+ # Drop on next release, only needed for lld patch
+ eautoreconf
+}
+
multilib_src_configure() {
# The build system will install libbsd-ctor.a despite USE="-static-libs"
# which is correct, see: