summaryrefslogtreecommitdiff
path: root/dev-libs/libansilove/libansilove-1.2.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libansilove/libansilove-1.2.9.ebuild')
-rw-r--r--dev-libs/libansilove/libansilove-1.2.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libansilove/libansilove-1.2.9.ebuild b/dev-libs/libansilove/libansilove-1.2.9.ebuild
new file mode 100644
index 000000000000..dd28dd03edd7
--- /dev/null
+++ b/dev-libs/libansilove/libansilove-1.2.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="library to convert ANSi and artscene related file formats into PNG images"
+HOMEPAGE="https://github.com/ansilove/libansilove"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="media-libs/gd:2=[png]"
+DEPEND="${RDEPEND}"