summaryrefslogtreecommitdiff
path: root/dev-libs/keystone/keystone-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/keystone/keystone-9999.ebuild')
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index 68f71673a12f..a6f8dcdd8897 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -56,6 +56,10 @@ wrap_python() {
fi
}
+pkg_setup() {
+ python_setup
+}
+
src_prepare() {
default
@@ -73,6 +77,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake_src_configure