summaryrefslogtreecommitdiff
path: root/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/keybinder/keybinder-0.3.1-r201.ebuild')
-rw-r--r--dev-libs/keybinder/keybinder-0.3.1-r201.ebuild22
1 files changed, 4 insertions, 18 deletions
diff --git a/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild b/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
index 711dd04ba10d..02e68ac665c5 100644
--- a/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
+++ b/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
@@ -1,11 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1
-
DESCRIPTION="A library for registering global keyboard shortcuts"
HOMEPAGE="https://github.com/kupferlauncher/keybinder"
SRC_URI="https://github.com/kupferlauncher/keybinder/releases/download/v${PV}/${P}.tar.gz"
@@ -13,32 +10,21 @@ SRC_URI="https://github.com/kupferlauncher/keybinder/releases/download/v${PV}/${
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 x86"
-IUSE="+introspection lua python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+introspection lua"
RDEPEND=">=x11-libs/gtk+-2.20:2
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
introspection? ( dev-libs/gobject-introspection )
- lua? ( >=dev-lang/lua-5.1 )
- python? ( ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/pygobject-2.15.3:2[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
- ')
- )"
+ lua? ( >=dev-lang/lua-5.1 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_configure() {
local myconf=(
$(use_enable introspection)
- $(use_enable python)
+ --disable-python
)
# upstream failed at AC_ARG_ENABLE
use lua || myconf+=( --disable-lua )