summaryrefslogtreecommitdiff
path: root/dev-libs/jthread/jthread-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jthread/jthread-1.3.3.ebuild')
-rw-r--r--dev-libs/jthread/jthread-1.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/jthread/jthread-1.3.3.ebuild b/dev-libs/jthread/jthread-1.3.3.ebuild
new file mode 100644
index 000000000000..e854d07537d5
--- /dev/null
+++ b/dev-libs/jthread/jthread-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
+HOMEPAGE="http://research.edm.uhasselt.be/jori/page/CS/Jthread.html"
+SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+DOCS=( ChangeLog README.md doc/manual.tex )
+
+src_prepare() {
+ # do not build static library, if it is not requested
+ if ! use static-libs; then
+ sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
+ fi
+ cmake-utils_src_prepare
+}