summaryrefslogtreecommitdiff
path: root/dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch')
-rw-r--r--dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch b/dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch
new file mode 100644
index 000000000000..fbfdfd32dffe
--- /dev/null
+++ b/dev-libs/intel-neo/files/intel-neo-19.16.12873_cmake_no_libva_automagic.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -374,9 +374,9 @@
+ endif()
+
+ # LibVA detection
+-if(UNIX)
++if(UNIX AND ENABLE_VAAPI_MEDIA_SHARING)
+ set(IGDRCL__LIBVA_IS_REQUIRED "")
+- if(IGDRCL_FORCE_USE_LIBVA)
++ if(IGDRCL_FORCE_USE_LIBVA OR ENABLE_VAAPI_MEDIA_SHARING)
+ set(IGDRCL__LIBVA_IS_REQUIRED "REQUIRED")
+ endif()
+