summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild')
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
index 4b6c563cdd2a..fb7f4bdf494f 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
@@ -7,7 +7,7 @@ CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
HOMEPAGE="https://github.com/intel/compute-runtime"
@@ -44,6 +44,9 @@ DOCS=( "README.md" "FAQ.md" )
PATCHES=( "${FILESDIR}/${PN}-22.12.22749-metrics.patch" )
src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_LIBDIR="$(get_libdir)"