summaryrefslogtreecommitdiff
path: root/dev-libs/inih/inih-52.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/inih/inih-52.ebuild')
-rw-r--r--dev-libs/inih/inih-52.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-52.ebuild b/dev-libs/inih/inih-52.ebuild
new file mode 100644
index 000000000000..643c90ef2a42
--- /dev/null
+++ b/dev-libs/inih/inih-52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}