summaryrefslogtreecommitdiff
path: root/dev-libs/imath/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/imath/files')
-rw-r--r--dev-libs/imath/files/imath-3.1.11-fix_cmake_module_export.patch22
-rw-r--r--dev-libs/imath/files/imath-3.1.11-use-correct-boost_python_version.patch17
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/imath/files/imath-3.1.11-fix_cmake_module_export.patch b/dev-libs/imath/files/imath-3.1.11-fix_cmake_module_export.patch
new file mode 100644
index 000000000000..3e5c4d59946c
--- /dev/null
+++ b/dev-libs/imath/files/imath-3.1.11-fix_cmake_module_export.patch
@@ -0,0 +1,22 @@
+From 0f7f9f9f32ea178d474325ec1b2576a790e336a1 Mon Sep 17 00:00:00 2001
+From: Lucas Miller <lmiller@imageworks.com>
+Date: Wed, 1 May 2024 13:51:30 -0700
+Subject: [PATCH] Address Issue #395 where packages that need to link against
+ PyImath can no longer find it.
+
+---
+ src/python/config/ModuleDefine.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/python/config/ModuleDefine.cmake b/src/python/config/ModuleDefine.cmake
+index adee61c8..b4063623 100644
+--- a/src/python/config/ModuleDefine.cmake
++++ b/src/python/config/ModuleDefine.cmake
+@@ -55,6 +55,7 @@ function(PYIMATH_ADD_LIBRARY_PRIV libname)
+ add_library(${PROJECT_NAME}::${libname} ALIAS ${libname})
+
+ install(TARGETS ${libname}
++ EXPORT ${PROJECT_NAME}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
diff --git a/dev-libs/imath/files/imath-3.1.11-use-correct-boost_python_version.patch b/dev-libs/imath/files/imath-3.1.11-use-correct-boost_python_version.patch
new file mode 100644
index 000000000000..fedd1005f6b6
--- /dev/null
+++ b/dev-libs/imath/files/imath-3.1.11-use-correct-boost_python_version.patch
@@ -0,0 +1,17 @@
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+Date: 2024-06-03
+Subject: [PATCH] only try to find versioned boost::python
+
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 1bc1e54..c71ce42 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -139,8 +139,6 @@ if(Boost_NO_BOOST_CMAKE)
+ endif()
+
+ find_package(Boost OPTIONAL_COMPONENTS
+- python
+- python${Python_VERSION_MAJOR}
+ ${PYIMATH_BOOST_PY_COMPONENT})
+ set(_pyimath_have_perver_boost)
+ if(PYIMATH_BOOST_PY_COMPONENT)