summaryrefslogtreecommitdiff
path: root/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild')
-rw-r--r--dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
new file mode 100644
index 000000000000..e0e5d1ce1547
--- /dev/null
+++ b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="iLBC is a speech codec suitable for robust voice communication over IP"
+HOMEPAGE="https://webrtc.org/license/ilbc-freeware/"
+SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz -> ${P}.tar.gz"
+
+# relicensed under 3-clause BSD license, bug 390797
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
+
+RDEPEND="!media-libs/libilbc"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}