summaryrefslogtreecommitdiff
path: root/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild')
-rw-r--r--dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild
index 075b530085fd..c93ceda1bb01 100644
--- a/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild
+++ b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r1.ebuild
@@ -1,29 +1,34 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="iLBC is a speech codec suitable for robust voice communication over IP"
HOMEPAGE="https://webrtc.org/license/ilbc-freeware/"
-SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz"
+SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz -> ${P}.tar.gz"
# relicensed under 3-clause BSD license, bug 390797
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-asneeded.patch
+src_prepare() {
+ default
eautoreconf
}
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
+ default
+ find "${D}" -name '*.la' -delete || die
}