summaryrefslogtreecommitdiff
path: root/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild')
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild
new file mode 100644
index 000000000000..d042b8fb75ba
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+COMMIT=4d29e48433270a2af06b8bc711ca1fe5109746cd
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+SRC_URI="https://github.com/hyprwm/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+KEYWORDS="~amd64"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"