summaryrefslogtreecommitdiff
path: root/dev-libs/hidapi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hidapi')
-rw-r--r--dev-libs/hidapi/Manifest5
-rw-r--r--dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild75
-rw-r--r--dev-libs/hidapi/metadata.xml22
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/hidapi/Manifest b/dev-libs/hidapi/Manifest
new file mode 100644
index 000000000000..1fa0cb3a34f6
--- /dev/null
+++ b/dev-libs/hidapi/Manifest
@@ -0,0 +1,5 @@
+DIST hidapi-0.8.0_rc1_p20140719.tgz 103079 SHA256 33e206f5e145fc1bc6aeb55084d71b55d686533d23ad5bb762746ceba81e728b SHA512 204934a707da4e67b834823650b0cfd9be7b413972071129cc5aeeb93465834dde2f5ee23283c55d35b56e3aed8b7ad5fe947399839081f4d895fb65c8cd3e3d WHIRLPOOL 3c7d9cc4f39ebbe1f372a2e4f60990b1127e0c3025b85648d0f114ef652634e8e09d3ccd9e8f26ee6db191db1b2ccbb7afea3c3fa2018e8dfce034679c051f47
+EBUILD hidapi-0.8.0_rc1_p20140719.ebuild 1918 SHA256 094b5e10ef9adeea58e43cc63933c45ee2c3c3012634a40c758ad6edcd9f2d05 SHA512 e3a4c5bc1767491641b6249f2552790f6e27aeb8309c3435ee29fbcfdfef483c2b550c54fd2e6d1ee24ecff0e10f10813e78606fb11e9ea75367511bddeaec3b WHIRLPOOL cb0ddf78c4d759371d5e7280e9e1b32b38b777f9999ea9876ea8619b2657d117247894582088bcfeb2f6d4f863451ad7a91521799bc5f5c857d3e2ddde682d19
+MISC ChangeLog 3483 SHA256 d2e9bfc3d26794a9f5157c340c21054c92a649583652f32bc9989189a07b6e95 SHA512 ab37b80003501cfb8eb900320c05e997a0bfb65a05078c013cb0562463d7a38ae9bc245071be49df1c4071163ab45a376ae26711936b452c06687ba436762e98 WHIRLPOOL f98b046f0104360e58f8074040ef6c459c17d659bb2992cf393ad7cdd3957062ae8b2fcb3a2db0aabc5e7c3a8330af3c2ba79928cbaca8d108aa9d2e5db5da8a
+MISC ChangeLog-2015 1833 SHA256 80cdc1e738e7bcaf29a8774fe60468fe701b041187b220df853f7c57a79704c7 SHA512 a33de9deaa6d1ead73416456d59eabc847a872d9113eef66ff3a39b0972afc97d2b410317367f841a60b99732f1bbebb4cf7717dd421fafd7931423d40a052ad WHIRLPOOL a6cc00c9a3e9d189f6c0a98a23ffa96c2fabac30792756138d0e1dd24225b4cf1280adc1c680af510cdc21f001306a8c3b4c9bc52fde10745df838883af4a3b4
+MISC metadata.xml 659 SHA256 d8b3ef2e7cf8853333494590690b6e2c7575101fb7e1a0e36042d17880dd22a6 SHA512 36bae2c3d3cb19327990c2df04a591d77ee8a8d5f0b269b636902156e2e8315e00fbad6f1f8fac9776598b42423f4ab626ee8b576b897ad5b92ef7d2f3081e58 WHIRLPOOL c354e5b9c1c1dd730a5fddfbf76f81d1506850e3bc38ec8cd235c2955dc0994decf7ecc9b86c10971769ec22b9f00cb7b15ab43d9cdf91f4528a786f3a031792
diff --git a/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild
new file mode 100644
index 000000000000..9cefcad3a4c8
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit eutils versionator autotools-multilib #git-2
+
+# If github is desired, the following may be used.
+#EGIT_REPO_URI="https://github.com/signal11/hidapi.git"
+#EGIT_BRANCH="master"
+EGIT_COMMIT="d17db57b9d4354752e0af42f5f33007a42ef2906"
+
+# S is only needed for the debian_package
+S=${WORKDIR}/${PN}-${DEBIAN_PV}
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="http://www.signal11.us/oss/hidapi/"
+SRC_URI="https://github.com/signal11/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tgz"
+# When 0.8.0 is officially available the following link should be used.
+#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="doc fox static-libs"
+
+RDEPEND="virtual/libusb:1[${MULTILIB_USEDEP}]
+ virtual/libudev:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ fox? ( x11-libs/fox )"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ if ! use fox; then
+ sed -i -e 's:PKG_CHECK_MODULES(\[fox\], .*):AC_SUBST(fox_CFLAGS,[ ])AC_SUBST(fox_LIBS,[ ]):' configure.ac || die
+ fi
+
+ # Fix bashisms in the configure.ac file.
+ sed -i -e 's:\([A-Z_]\+\)+="\(.*\)":\1="${\1}\2":g' \
+ -e 's:\([A-Z_]\+\)+=`\(.*\)`:\1="${\1}\2":g' configure.ac || die
+
+ # Portage handles license texts itself, no need to install them
+ sed -i -e 's/LICENSE.*/ # blank/' Makefile.am || die
+
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(multilib_native_use_enable fox testgui)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-multilib_src_compile
+
+ if use doc; then
+ doxygen doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc; then
+ dohtml -r html/.
+ fi
+}
diff --git a/dev-libs/hidapi/metadata.xml b/dev-libs/hidapi/metadata.xml
new file mode 100644
index 000000000000..d5b410c9655d
--- /dev/null
+++ b/dev-libs/hidapi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="fox">Build a x11-libs/fox GUI</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">signal11/hidapi</remote-id>
+ </upstream>
+</pkgmetadata>