summaryrefslogtreecommitdiff
path: root/dev-libs/half/half-1.12.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/half/half-1.12.0-r1.ebuild')
-rw-r--r--dev-libs/half/half-1.12.0-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-libs/half/half-1.12.0-r1.ebuild b/dev-libs/half/half-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..ce8d4509174c
--- /dev/null
+++ b/dev-libs/half/half-1.12.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Half-precision floating-point library"
+HOMEPAGE="https://github.com/ROCm/half"
+SRC_URI="https://github.com/ROCm/half/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+src_install() {
+ insinto /usr/include/half
+ doins include/half.hpp
+}