summaryrefslogtreecommitdiff
path: root/dev-libs/grok/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/grok/files')
-rw-r--r--dev-libs/grok/files/0.9.2-Makefile.patch65
-rw-r--r--dev-libs/grok/files/0.9.2-build-with-pcre-lt-8.34.patch15
-rw-r--r--dev-libs/grok/files/grok-0.9.2-Makefile.patch63
-rw-r--r--dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch26
-rw-r--r--dev-libs/grok/files/grok-0.9.2-libdir.patch28
-rw-r--r--dev-libs/grok/files/grok-0.9.2-libtirpc.patch21
6 files changed, 0 insertions, 218 deletions
diff --git a/dev-libs/grok/files/0.9.2-Makefile.patch b/dev-libs/grok/files/0.9.2-Makefile.patch
deleted file mode 100644
index f10531646ad0..000000000000
--- a/dev-libs/grok/files/0.9.2-Makefile.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/grok-0.9.2/Makefile b/grok-0.9.2/Makefile
-index adfe869..fdced25 100644
---- a/grok-0.9.2/Makefile
-+++ b/grok-0.9.2/Makefile
-@@ -25,10 +25,12 @@ else
- GPERF?=/usr/bin/gperf
- endif
-
-+LIBS=-lpcre -levent -rdynamic -ltokyocabinet
-+
- # For linux, we need libdl for dlopen()
- # On FreeBSD, comment this line out.
- ifeq ($(PLATFORM), GNULinux)
--LDFLAGS+=-ldl
-+LIBS+=-ldl
- endif
-
- # #############################################
-@@ -41,8 +43,7 @@ VERSION=$(shell sh $(BASE)/version.sh)
- #CFLAGS+=-g
- #LDFLAGS+=-g
-
--CFLAGS+=-pipe -fPIC -I. -O2
--LDFLAGS+=-lpcre -levent -rdynamic -ltokyocabinet
-+CFLAGS+=-fPIC -I.
-
- LIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix)
- VERLIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix $(MAJOR))
-@@ -50,8 +51,8 @@ DYNLIBFLAG=$(shell sh $(BASE)/platform.sh dynlibflag)
- LIBNAMEFLAG=$(shell sh $(BASE)/platform.sh libnameflag $(MAJOR) $(INSTALLLIB))
-
- # Sane includes
--CFLAGS+=-I/usr/local/include
--LDFLAGS+=-L/usr/local/lib
-+#CFLAGS+=-I/usr/local/include
-+#LDFLAGS+=-L/usr/local/lib
-
- # Platform so we know what to dlopen
- CFLAGS+=-DPLATFORM_$(PLATFORM)
-@@ -97,6 +98,7 @@ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
- install -m 755 grok $(DESTDIR)$(PREFIX)/bin
- install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
- install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
-+ ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX).1
- for header in $(GROKHEADER); do \
- install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
- done
-@@ -162,14 +164,14 @@ cleanver:
- # Binary creation
- grok: LDFLAGS+=-levent
- grok: $(GROKOBJ) conf.tab.o conf.yy.o main.o grok_config.o
-- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- discogrok: $(GROKOBJ) discover_main.o
-- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- libgrok.$(LIBSUFFIX):
- libgrok.$(LIBSUFFIX): $(GROKOBJ)
-- $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ -o $@
-+ $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ $(LIBS) -o $@
-
- libgrok.$(VERLIBSUFFIX): libgrok.$(LIBSUFFIX);
- ln -s $< $@
diff --git a/dev-libs/grok/files/0.9.2-build-with-pcre-lt-8.34.patch b/dev-libs/grok/files/0.9.2-build-with-pcre-lt-8.34.patch
deleted file mode 100644
index 1593ac309817..000000000000
--- a/dev-libs/grok/files/0.9.2-build-with-pcre-lt-8.34.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/jordansissel/grok/commit/44ce9372a29319c01d4ac7f24287fb36315e0e34
-
---- a/grokre.c
-+++ b/grokre.c
-@@ -12,8 +12,8 @@
-
- /* global, static variables */
-
--#define CAPTURE_ID_LEN 4
--#define CAPTURE_FORMAT "%04x"
-+#define CAPTURE_ID_LEN 5
-+#define CAPTURE_FORMAT "_%04x"
-
- /* internal functions */
- static char *grok_pattern_expand(grok_t *grok); //, int offset, int length);
diff --git a/dev-libs/grok/files/grok-0.9.2-Makefile.patch b/dev-libs/grok/files/grok-0.9.2-Makefile.patch
deleted file mode 100644
index 8d9351c8c0f8..000000000000
--- a/dev-libs/grok/files/grok-0.9.2-Makefile.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -25,10 +25,12 @@ else
- GPERF?=/usr/bin/gperf
- endif
-
-+LIBS=-lpcre -levent -rdynamic -ltokyocabinet
-+
- # For linux, we need libdl for dlopen()
- # On FreeBSD, comment this line out.
- ifeq ($(PLATFORM), GNULinux)
--LDFLAGS+=-ldl
-+LIBS+=-ldl
- endif
-
- # #############################################
-@@ -41,8 +43,7 @@ VERSION=$(shell sh $(BASE)/version.sh)
- #CFLAGS+=-g
- #LDFLAGS+=-g
-
--CFLAGS+=-pipe -fPIC -I. -O2
--LDFLAGS+=-lpcre -levent -rdynamic -ltokyocabinet
-+CFLAGS+=-fPIC -I.
-
- LIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix)
- VERLIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix $(MAJOR))
-@@ -50,8 +51,8 @@ DYNLIBFLAG=$(shell sh $(BASE)/platform.sh dynlibflag)
- LIBNAMEFLAG=$(shell sh $(BASE)/platform.sh libnameflag $(MAJOR) $(INSTALLLIB))
-
- # Sane includes
--CFLAGS+=-I/usr/local/include
--LDFLAGS+=-L/usr/local/lib
-+#CFLAGS+=-I/usr/local/include
-+#LDFLAGS+=-L/usr/local/lib
-
- # Platform so we know what to dlopen
- CFLAGS+=-DPLATFORM_$(PLATFORM)
-@@ -97,6 +98,7 @@ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
- install -m 755 grok $(DESTDIR)$(PREFIX)/bin
- install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
- install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
-+ ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX).1
- for header in $(GROKHEADER); do \
- install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
- done
-@@ -162,14 +164,14 @@ cleanver:
- # Binary creation
- grok: LDFLAGS+=-levent
- grok: $(GROKOBJ) conf.tab.o conf.yy.o main.o grok_config.o
-- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- discogrok: $(GROKOBJ) discover_main.o
-- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- libgrok.$(LIBSUFFIX):
- libgrok.$(LIBSUFFIX): $(GROKOBJ)
-- $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ -o $@
-+ $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ $(LIBS) -o $@
-
- libgrok.$(VERLIBSUFFIX): libgrok.$(LIBSUFFIX);
- ln -s $< $@
diff --git a/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch b/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch
deleted file mode 100644
index 89300eb5f6e9..000000000000
--- a/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Closes: https://github.com/jordansissel/grok/issues/28
-Closes: https://github.com/jordansissel/grok/issues/29
-
---- a/Makefile
-+++ b/Makefile
-@@ -213,8 +213,8 @@ grok_capture_xdr.h: grok_capture.x
- rpcgen -h $< -o $@
-
- %.c: %.gperf
-- @if $(GPERF) --version | head -1 | egrep -v '3\.[0-9]+\.[0-9]+' ; then \
-- echo "We require gperf version >= 3.0.3" ; \
-+ @if $(GPERF) --version | head -1 | grep --quiet -E '[0-2]\.[0-9]\.[0-9]+|3\.0\.[0-9]+' ; then \
-+ echo "We require gperf version >= 3.1.0" ; \
- exit 1; \
- fi
- $(GPERF) $< > $@
---- a/grok_matchconf_macro.h
-+++ b/grok_matchconf_macro.h
-@@ -19,6 +19,6 @@ struct strmacro {
- #endif
-
- /* this function is generated by gperf */
--const struct strmacro *patname2macro(const char *str, unsigned int len);
-+const struct strmacro *patname2macro(const char *str, size_t len);
-
- #endif /* _GROK_MATCHCONF_MACRO_ */
diff --git a/dev-libs/grok/files/grok-0.9.2-libdir.patch b/dev-libs/grok/files/grok-0.9.2-libdir.patch
deleted file mode 100644
index 06b19555cde8..000000000000
--- a/dev-libs/grok/files/grok-0.9.2-libdir.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ruN grok-0.9.2.orig/Makefile grok-0.9.2/Makefile
---- grok-0.9.2.orig/Makefile 2018-05-05 17:26:35.451938040 +0200
-+++ grok-0.9.2/Makefile 2018-05-05 17:29:03.414780593 +0200
-@@ -93,12 +93,12 @@
-
- install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
- install -d $(DESTDIR)$(PREFIX)/bin
-- install -d $(DESTDIR)$(PREFIX)/lib
-+ install -d $(DESTDIR)$(PREFIX)/$(LIBDIR)
- install -d $(DESTDIR)$(PREFIX)/include
- install -m 755 grok $(DESTDIR)$(PREFIX)/bin
- install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
-- install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
-- ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX).1
-+ install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/$(LIBDIR)
-+ ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libgrok.$(LIBSUFFIX).1
- for header in $(GROKHEADER); do \
- install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
- done
-@@ -109,7 +109,7 @@
- uninstall:
- rm -f $(DESTDIR)$(PREFIX)/bin/grok
- rm -f $(DESTDIR)$(PREFIX)/bin/discogrok
-- rm -f $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX)
-+ rm -f $(DESTDIR)$(PREFIX)/$(LIBDIR)/libgrok.$(LIBSUFFIX)
- for header in $(GROKHEADER); do \
- rm -f $(DESTDIR)$(PREFIX)/include/$$header; \
- done
diff --git a/dev-libs/grok/files/grok-0.9.2-libtirpc.patch b/dev-libs/grok/files/grok-0.9.2-libtirpc.patch
deleted file mode 100644
index 9fd09bef8252..000000000000
--- a/dev-libs/grok/files/grok-0.9.2-libtirpc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN grok-0.9.2.orig/Makefile grok-0.9.2/Makefile
---- grok-0.9.2.orig/Makefile 2018-05-05 17:22:33.122558130 +0200
-+++ grok-0.9.2/Makefile 2018-05-05 17:24:29.554221133 +0200
-@@ -25,7 +25,7 @@
- GPERF?=/usr/bin/gperf
- endif
-
--LIBS=-lpcre -levent -rdynamic -ltokyocabinet
-+LIBS=-lpcre -levent -rdynamic -ltokyocabinet -ltirpc
-
- # For linux, we need libdl for dlopen()
- # On FreeBSD, comment this line out.
-@@ -55,7 +55,7 @@
- #LDFLAGS+=-L/usr/local/lib
-
- # Platform so we know what to dlopen
--CFLAGS+=-DPLATFORM_$(PLATFORM)
-+CFLAGS+=-DPLATFORM_$(PLATFORM) -I$(EPREFIX)/usr/include/tirpc
- # Uncomment to totally disable logging features
- #CFLAGS+=-DNOLOGGING
-