summaryrefslogtreecommitdiff
path: root/dev-libs/grantlee/grantlee-5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/grantlee/grantlee-5.1.0.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
index d8de4e45a9f6..8bcda9a613cb 100644
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx
@@ -15,25 +15,26 @@ SLOT="5"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
IUSE="debug doc test"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtscript:5
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
test? ( dev-qt/qttest:5 )
"
# bug 682258
RESTRICT="test"
-DOCS=( AUTHORS CHANGELOG README.md )
-
PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
"${FILESDIR}/${P}-slot.patch"
"${FILESDIR}/${P}-qt-5.13.patch"
+ "${FILESDIR}/${P}-cxx11.patch"
)
src_prepare() {