summaryrefslogtreecommitdiff
path: root/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch')
-rw-r--r--dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
new file mode 100644
index 000000000000..a25f52b3c63d
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
@@ -0,0 +1,14 @@
+diff -ruN grantlee-0.3.0.orig/CMakeLists.txt grantlee-0.3.0/CMakeLists.txt
+--- grantlee-0.3.0.orig/CMakeLists.txt 2012-11-01 21:14:18.000000000 +0100
++++ grantlee-0.3.0/CMakeLists.txt 2013-03-09 12:25:56.498096399 +0100
+@@ -62,8 +62,8 @@
+ endif()
+
+ if (NOT APPLE)
+- set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
+- set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
++ set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
++ set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
+ endif ()
+
+ if (NOT MINGW)