summaryrefslogtreecommitdiff
path: root/dev-libs/gost-engine/gost-engine-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gost-engine/gost-engine-9999.ebuild')
-rw-r--r--dev-libs/gost-engine/gost-engine-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-libs/gost-engine/gost-engine-9999.ebuild b/dev-libs/gost-engine/gost-engine-9999.ebuild
index 782e02fbd454..424b0bc09f56 100644
--- a/dev-libs/gost-engine/gost-engine-9999.ebuild
+++ b/dev-libs/gost-engine/gost-engine-9999.ebuild
@@ -7,11 +7,17 @@ inherit cmake-utils
DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
HOMEPAGE="https://github.com/gost-engine/engine"
-
+IUSE="test"
+RESTRICT="!test? ( test )"
SLOT="0/${PV}"
-DEPEND=">=dev-libs/openssl-1.1:0="
-RDEPEND="${DEPEND}"
+COMMON_DEPEND=">=dev-libs/openssl-1.1:0="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-lang/perl
+ )"
+RDEPEND="${COMMON_DEPEND}"
LICENSE="openssl"