summaryrefslogtreecommitdiff
path: root/dev-libs/go-usb/go-usb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/go-usb/go-usb-9999.ebuild')
-rw-r--r--dev-libs/go-usb/go-usb-9999.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-libs/go-usb/go-usb-9999.ebuild b/dev-libs/go-usb/go-usb-9999.ebuild
deleted file mode 100644
index 1cc0b177b86e..000000000000
--- a/dev-libs/go-usb/go-usb-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit git-r3
-
-DESCRIPTION="CGO bindings for libusb"
-HOMEPAGE="https://github.com/hanwen/usb"
-EGIT_REPO_URI="https://github.com/hanwen/usb.git"
-
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND=">=dev-lang/go-1.4"
-
-# Tests require a connected mtp device
-RESTRICT="test"
-
-GO_PN="/usr/lib/go/src/github.com/hanwen/usb"
-
-src_test() {
- go test -ldflags '-extldflags=-fno-PIC' ${GO_PN} || die
-}
-
-src_install() {
- insinto "${GO_PN}"
- doins *.go LICENSE
-}