summaryrefslogtreecommitdiff
path: root/dev-libs/go-fuse
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/go-fuse')
-rw-r--r--dev-libs/go-fuse/Manifest6
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild55
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20150422.ebuild53
-rw-r--r--dev-libs/go-fuse/go-fuse-9999.ebuild53
-rw-r--r--dev-libs/go-fuse/metadata.xml8
5 files changed, 0 insertions, 175 deletions
diff --git a/dev-libs/go-fuse/Manifest b/dev-libs/go-fuse/Manifest
deleted file mode 100644
index fcea8cfcee5f..000000000000
--- a/dev-libs/go-fuse/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-DIST go-fuse-0_p20140812.tar.gz 111389 BLAKE2B 13cc74fb8844b0486e593ab62e5564111d0a01361edfb3be4c8b0ae3bc298d0043ad80a33318a407236e74f0d9bcea2f87ba4681db4d34ad8818a32b8fa0e459 SHA512 d951094e290bc914b418c165106368d6b73634ffb177b770ce53baaca4cd6026967f11d602b3e687e59a49323c7af1af74913ec1a911093e4e32503025842cb3
-DIST go-fuse-0_p20150422.tar.gz 110741 BLAKE2B 4c01af2a86a97ea9d0309066bc032aa41847b74edc18bc91483fbc789e143f297c90c7fe89f7c376ec0f12859d337a271122884bab79b4e9a94f95bacb63e426 SHA512 a0c9fa666ab39632db258baa5bf6ba1546aa847beb0d4a4b812a96e66d8573e3c0a0600ad24e16e314fbd8082b36027a3e1bc2092667766f611b1321aaea70c5
-EBUILD go-fuse-0_p20140812-r1.ebuild 1378 BLAKE2B 864e049e76dcb7108bccb553fcd76854b0b110c829d5f1b45138492669c9841f6dc22024aae1244cdcafa32cb5dba9bb4c5f7c521fc1e6c25008b824f09fbfb7 SHA512 0a157e7664d801c3b2318c4ec04f5ffe01a2e2406f64b6edd5dae60b178bec75cf04ff44f6a56b3da29d331ddc98d6e7a2208ea0ba916d6d6cebc352cb1eca70
-EBUILD go-fuse-0_p20150422.ebuild 1173 BLAKE2B 434725573159f029575a857c8182227a039af469dd584a56da1e1445703b71ea79423ea1619c0d9bfcf5b3f148d018a922018ae99cfb448ff179118cb10fad1f SHA512 8af3d601d8741f7cc7223c75db5bd3ecf281920a113555449cd5b494ad567969d8ff7a5a1b3c10d7fa52e59be82a9fff8236eab5f64f1a0628b710eadec7539c
-EBUILD go-fuse-9999.ebuild 1252 BLAKE2B ef765f5b5aae88905322863d107a4a0e93ee27951b5012db404ec74368a7252905ddde07e83aed654bf2d7a58bd69eef985c1e3c32f53cfd6a4a6510c5b0232c SHA512 cd0e37fb26f4ca74dd257977862417d7995fa5d6a2e08a2050325465506c484f3f016f7d96391cd06da926ad4bc1cb3610b6721fcee7f446454776f3759ea325
-MISC metadata.xml 252 BLAKE2B 27f76196891876b131efab2ee91a373a4be28501e24b75c97bcf486a64938c1e87f1e047c6ba506026133b425a91eadc7f8dc9b778ce44120b1dceba0e8d395f SHA512 ba6b0c313e9744f9b0cc7c29849e9adb9ce5b725a72dc30de22b7a4bad5237c18ae7647cd7d75fd5d8855a4bdf0dd45cea7f6c79722660df63395bed1217b967
diff --git a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
deleted file mode 100644
index 0ff5a2228922..000000000000
--- a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vcs-clean
-
-GO_PN=github.com/hanwen/${PN}
-EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
-
-HOMEPAGE="https://github.com/hanwen/go-fuse"
-DESCRIPTION="FUSE bindings for Go"
-SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND=">=dev-lang/go-1.3"
-
-RESTRICT="strip"
-
-src_unpack() {
- default_src_unpack
- mkdir -p src/${GO_PN%/*} || die
- mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
-}
-
-src_prepare() {
- sed -e "s:\(go \${target}\)\(.*\)$:\\1 -x \\2:" \
- -e 's:^for target in "clean" "install" ; do$:for target in "install" ; do:' \
- -e '17,26d' \
- src/${GO_PN}/all.bash > src/${GO_PN}/all.bash.patched || die
-}
-
-src_compile() {
- # Create a filtered GOROOT tree out of symlinks,
- # excluding go-fuse, for bug #503324.
- cp -sR /usr/lib/go goroot || die
- rm -rf goroot/src/${GO_PN} || die
- rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
- CGO_CFLAGS="${CFLAGS}" GOROOT="${WORKDIR}/goroot" GOPATH="${WORKDIR}" \
- bash src/${GO_PN}/all.bash.patched || die
-}
-
-src_install() {
- insopts -m0644 -p # preserve timestamps for bug 551486
- insinto /usr/lib/go
- doins -r pkg
- insinto /usr/lib/go/src
- rm src/${GO_PN}/all.bash.patched || die
- egit_clean src/${GO_PN}
- doins -r src/*
-}
diff --git a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
deleted file mode 100644
index 2a069dc0c67c..000000000000
--- a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vcs-clean
-
-GO_PN=github.com/hanwen/${PN}
-EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"
-
-HOMEPAGE="https://github.com/hanwen/go-fuse"
-DESCRIPTION="FUSE bindings for Go"
-SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND=">=dev-lang/go-1.3"
-
-RESTRICT="strip"
-
-src_unpack() {
- default_src_unpack
- mkdir -p "${S}/src/${GO_PN%/*}" || die
- mv ${PN}-${EGIT_COMMIT} "${S}/src/${GO_PN}" || die
- egit_clean
-}
-
-call_go() {
- local d
- for d in fuse fuse/pathfs zipfs unionfs; do
- GOROOT="${GOROOT}" GOPATH="${S}" \
- go "${1}" -v -x -work ${GO_PN}/${d} || die
- done
-}
-
-src_compile() {
- # Create a filtered GOROOT tree out of symlinks,
- # excluding go-fuse, for bug #503324.
- GOROOT="${WORKDIR}/goroot"
- cp -sR /usr/lib/go "${GOROOT}" || die
- rm -rf "${GOROOT}/src/${GO_PN}" || die
- rm -rf "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
- call_go build
-}
-
-src_install() {
- call_go install
- insopts -m0644 -p # preserve timestamps for bug 551486
- insinto /usr/lib/go
- doins -r pkg src
-}
diff --git a/dev-libs/go-fuse/go-fuse-9999.ebuild b/dev-libs/go-fuse/go-fuse-9999.ebuild
deleted file mode 100644
index a745fe10ed3a..000000000000
--- a/dev-libs/go-fuse/go-fuse-9999.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit git-r3 vcs-clean
-
-DESCRIPTION="native bindings for the FUSE kernel module"
-HOMEPAGE="https://github.com/hanwen/go-fuse"
-EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
-
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND=">=dev-lang/go-1.3"
-
-RESTRICT="strip"
-
-GO_PN="github.com/hanwen/${PN}"
-EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
-
-export GOPATH="${S}"
-
-src_compile() {
- local d
- #no examples right now
- # example/hello example/loopback example/zipfs \
- # example/multizip example/unionfs example/memfs \
- # example/autounionfs ; \
- #or tests
- #fuse/test
- for d in fuse fuse/pathfs zipfs unionfs; do
- go build -v -x -work ${GO_PN}/${d} || die
- done
-}
-
-src_install() {
- local d
- for d in fuse fuse/pathfs zipfs unionfs; do
- go install -v -x -work ${GO_PN}/${d} || die
- done
-
- insinto /usr/lib/go/
- doins -r "${S}/pkg"
- insinto "/usr/lib/go/src/${GO_PN}/"
-
- # for this ebuild, to fix bug #503324 I have limited what is installed
- # another possible solution would have been using adddeny to the
- # hide installed filed during build
- egit_clean "${S}/src/${GO_PN}"
- doins -r "${S}/src/${GO_PN}/fuse"
- doins -r "${S}/src/${GO_PN}/splice"
-}
diff --git a/dev-libs/go-fuse/metadata.xml b/dev-libs/go-fuse/metadata.xml
deleted file mode 100644
index 1b36939c7907..000000000000
--- a/dev-libs/go-fuse/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">hanwen/go-fuse</remote-id>
- </upstream>
-</pkgmetadata>