summaryrefslogtreecommitdiff
path: root/dev-libs/ffcall/ffcall-1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ffcall/ffcall-1.10.ebuild')
-rw-r--r--dev-libs/ffcall/ffcall-1.10.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-libs/ffcall/ffcall-1.10.ebuild b/dev-libs/ffcall/ffcall-1.10.ebuild
deleted file mode 100644
index 14a5a44b4581..000000000000
--- a/dev-libs/ffcall/ffcall-1.10.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="foreign function call libraries"
-HOMEPAGE="https://www.haible.de/bruno/packages-ffcall.html"
-SRC_URI="ftp://ftp.santafe.edu/pub/gnu/${P}.tar.gz"
-
-# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
-# or in derivate works of GNUstep, the included parts of ffcall are
-# under GNU LGPL." -ffcall author
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ppc sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- # Because CHOST is set to (for example)
- # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
- # doesn't work in the Makefile (29 Jan 2004 agriffis)
- local cpu_setting
- [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
-
- append-flags -fPIC
-
- econf || die "./configure failed"
- make ${cpu_setting} || die
-}
-
-src_install() {
- dodoc NEWS README
- dohtml avcall/avcall.html \
- callback/callback.html \
- callback/trampoline_r/trampoline_r.html \
- trampoline/trampoline.html \
- vacall/vacall.html
- doman avcall/avcall.3 \
- callback/callback.3 \
- callback/trampoline_r/trampoline_r.3 \
- trampoline/trampoline.3 \
- vacall/vacall.3
- dolib.a avcall/.libs/libavcall.a \
- avcall/.libs/libavcall.la \
- vacall/libvacall.a \
- callback/.libs/libcallback.a \
- callback/.libs/libcallback.la \
- trampoline/libtrampoline.a
- insinto /usr/include
- doins avcall/avcall.h \
- callback/callback.h \
- trampoline/trampoline.h \
- callback/trampoline_r/trampoline_r.h \
- vacall/vacall.h \
- callback/vacall_r.h
-}