summaryrefslogtreecommitdiff
path: root/dev-libs/ell/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ell/files')
-rw-r--r--dev-libs/ell/files/ell-0.35-add-missing-include-in-dhcp-server.patch24
-rw-r--r--dev-libs/ell/files/ell-0.35-add-rawmemchr-to-missing-h.patch44
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/ell/files/ell-0.35-add-missing-include-in-dhcp-server.patch b/dev-libs/ell/files/ell-0.35-add-missing-include-in-dhcp-server.patch
new file mode 100644
index 000000000000..788985ccd6fd
--- /dev/null
+++ b/dev-libs/ell/files/ell-0.35-add-missing-include-in-dhcp-server.patch
@@ -0,0 +1,24 @@
+From 6dfff19d4716ba216de1a3298ed0f667d7782810 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=89rico=20Nogueira?= <ericonr@disroot.org>
+Date: Mon, 30 Nov 2020 18:40:33 -0300
+Subject: ell: add missing include in dhcp-server.
+
+---
+ ell/dhcp-server.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ell/dhcp-server.c b/ell/dhcp-server.c
+index c983ed4..144e83e 100644
+--- a/ell/dhcp-server.c
++++ b/ell/dhcp-server.c
+@@ -24,6 +24,7 @@
+ #include <config.h>
+ #endif
+
++#include <linux/types.h>
+ #include <net/ethernet.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+--
+cgit 1.2.3-1.el7
+
diff --git a/dev-libs/ell/files/ell-0.35-add-rawmemchr-to-missing-h.patch b/dev-libs/ell/files/ell-0.35-add-rawmemchr-to-missing-h.patch
new file mode 100644
index 000000000000..2008b27d56ad
--- /dev/null
+++ b/dev-libs/ell/files/ell-0.35-add-rawmemchr-to-missing-h.patch
@@ -0,0 +1,44 @@
+From 3916c1cc32be205e185a8a56de5cde1b9ec60e81 Mon Sep 17 00:00:00 2001
+From: Denis Kenzior <denkenz@gmail.com>
+Date: Mon, 30 Nov 2020 13:00:11 -0600
+Subject: build: Add rawmemchr to missing.h
+
+For those systems (i.e. musl) that do not support this
+---
+ configure.ac | 1 +
+ ell/missing.h | 10 ++++++++++
+ 2 files changed, 11 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 1e5ead9..f34add1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -98,6 +98,7 @@ AC_ARG_ENABLE(ubsan, AC_HELP_STRING([--enable-ubsan],
+ ])
+
+ AC_CHECK_FUNCS(explicit_bzero)
++AC_CHECK_FUNCS(rawmemchr)
+
+ AC_CHECK_FUNC(signalfd, dummy=yes,
+ AC_MSG_ERROR(signalfd support is required))
+diff --git a/ell/missing.h b/ell/missing.h
+index 6b9b0fd..2a3e647 100644
+--- a/ell/missing.h
++++ b/ell/missing.h
+@@ -67,3 +67,13 @@ static inline void explicit_bzero(void *s, size_t n)
+ #ifndef SO_BINDTOIFINDEX
+ #define SO_BINDTOIFINDEX 62
+ #endif
++
++#ifndef HAVE_RAWMEMCHR
++static inline void *rawmemchr(const void *s, int c)
++{
++_Pragma("GCC diagnostic push")
++_Pragma("GCC diagnostic ignored \"-Wstringop-overflow=\"")
++ return memchr(s, c, (size_t) -1);
++_Pragma("GCC diagnostic pop")
++}
++#endif
+--
+cgit 1.2.3-1.el7
+