summaryrefslogtreecommitdiff
path: root/dev-libs/efl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/efl')
-rw-r--r--dev-libs/efl/Manifest4
-rw-r--r--dev-libs/efl/efl-1.25.1-r10.ebuild32
-rw-r--r--dev-libs/efl/efl-1.25.1-r2.ebuild28
3 files changed, 40 insertions, 24 deletions
diff --git a/dev-libs/efl/Manifest b/dev-libs/efl/Manifest
index e21eab06119d..e65561b2f4e0 100644
--- a/dev-libs/efl/Manifest
+++ b/dev-libs/efl/Manifest
@@ -1,4 +1,4 @@
DIST efl-1.25.1.tar.xz 72306872 BLAKE2B 060d729380ba62677307c5346da1786e879c14c4e40f0a3288c8cb81ece08f4ac501d989495b1c3dcbfeb19a86d23130892ae874861de5684c867aef60cb07d6 SHA512 cd281c2299aa6f74f0204e59a13dc254135e6dc40641e0a437c6f5025efe517d415f0915f69e123123319a9bbddb748aec1948ed0b5eb386e028cf45b244bed8
-EBUILD efl-1.25.1-r10.ebuild 7774 BLAKE2B 3787eb8fafd4e6277612a18850e5ecb296ff1373877249977e8c26b1f609b484ed8ffa8f18f2fdf48845b4bdb3db1c3f57c99ab9ed80d0339583ddceb3d2430c SHA512 b057178a6b6fa9e527bfbc1ac572930dd101f3bb64b16b159ecf51a3049e3dfae5c338ecdcd8438bf7e1e3be7851537ec3d1e2950b2728266e9610949883b28d
-EBUILD efl-1.25.1-r2.ebuild 7749 BLAKE2B 897961b06badff816a08a64d93f2ab9acfd548ca1bf812324f569cf64b55607cbff55702c57bd8b35dc5ca2086bcf5c64b3fc2ce01339510d8cc69ff727986a9 SHA512 9b6c8106e6027c46b3efc78a43c54bb49a9d785b6b87fe420aeaac8a467b0eabb9e6389d52bf93ab650ce8ead0f7e79a305a298d15383af49f609b63a2458a3e
+EBUILD efl-1.25.1-r10.ebuild 7898 BLAKE2B 9a8acb995a22f43c0df2ad120dbec0a2e7c2ba353d6d22bb13160683fa7bdcdb6b3ca7a311fe0bfaf2c073ba3e38c5dcd4fde05bcf837953c570995447694523 SHA512 f7c3ac6297714751667c334a6c63eafa2e65df569bba78749f8acb33a38f7dc8c663a68d25ee0f34320052a9f8698ba3124779dc5bfd6050b548020d7da9cc35
+EBUILD efl-1.25.1-r2.ebuild 7856 BLAKE2B 794aae8443dab4a98bbf0d38ce8da17b82b7b929d95903adcc9a3fba3b3cd30442a593571e422d66471ac3f7e85b948213861e5111f0547902930db9f996127f SHA512 759e0e824ddee8f70a0611fa7b695713c03fab01623dacf4379d3e0b6a985175872bb85751ff3368e9dc8f82e8a190573aa55f3f3288635415469f3a992b4e2b
MISC metadata.xml 1985 BLAKE2B 5ad17cbfc665a26357c6b8d473d211663224eca97ed9a22c8575122e331b9661118890db1cf4f41e9e0e9b16f157d48da0920026fc83fdf965e4d1bd7c3d1ede SHA512 dbc127099457c88bcc419bd0c415f801765aeb85f010d7de43ea03e9400a7888c33c80f53048bf4edfd34ff95a43ac506026775a7bf11b041adc89acef0ec15d
diff --git a/dev-libs/efl/efl-1.25.1-r10.ebuild b/dev-libs/efl/efl-1.25.1-r10.ebuild
index 778024e9b3f1..d6f621178a8a 100644
--- a/dev-libs/efl/efl-1.25.1-r10.ebuild
+++ b/dev-libs/efl/efl-1.25.1-r10.ebuild
@@ -5,7 +5,10 @@ EAPI=7
LUA_COMPAT=( lua5-{1..3} luajit )
-inherit lua-single meson xdg-utils
+DOCS_BUILDER="doxygen"
+DOCS_DIR="${S}/doc"
+
+inherit docs lua-single meson xdg-utils
DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
HOMEPAGE="https://www.enlightenment.org"
@@ -14,7 +17,7 @@ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${P}.tar.xz"
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="+X avif bmp connman cpu_flags_arm_neon dds debug doc drm +eet efl-one elogind examples fbcon
+IUSE="+X avif bmp connman cpu_flags_arm_neon dds debug drm +eet efl-one elogind examples fbcon
+fontconfig fribidi gif gles2-only gnutls glib +gstreamer harfbuzz hyphen ibus ico libressl
jpeg2k json nls mono opengl +pdf physics pmaps postscript psd pulseaudio raw scim
sdl +sound +ssl +svg +system-lz4 systemd tga tgv tiff tslib unwind v4l vnc wayland webp xcf
@@ -125,7 +128,6 @@ RDEPEND="${LUA_DEPS}
zeroconf? ( net-dns/avahi )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )
nls? ( sys-devel/gettext )"
pkg_setup() {
@@ -142,6 +144,17 @@ src_prepare() {
sed -i "/config_h.set('HAVE_UNWIND/,/eina_ext_deps += unwind/d" src/lib/eina/meson.build ||
die "Failed to remove libunwind dep"
fi
+
+ # Fixup Doxyfile
+ pushd "${DOCS_DIR}" || die
+ cp Doxyfile.in Doxyfile || die
+ sed -i \
+ -e "s/@PACKAGE_VERSION@/${PV}/g" \
+ -e "s/@top_builddir@/../g" \
+ -e "s/@top_srcdir@/../g" \
+ -e "s/@srcdir@/./g" \
+ Doxyfile || die
+ popd || die
}
src_configure() {
@@ -177,7 +190,7 @@ src_configure() {
$(meson_use gstreamer)
$(meson_use harfbuzz)
$(meson_use hyphen)
- $(meson_use lua_targets_luajit elua)
+ $(meson_use lua_single_target_luajit elua)
$(meson_use nls)
$(meson_use physics)
$(meson_use pulseaudio)
@@ -251,13 +264,13 @@ src_configure() {
emesonargs+=( -D ecore-imf-loaders-disabler="${disabledImfLoaders}" )
local bindingsList="cxx,"
- use lua_targets_luajit && bindingsList+="lua,"
+ use lua_single_target_luajit && bindingsList+="lua,"
use mono && bindingsList+="mono,"
[[ ! -z "$bindingsList" ]] && bindingsList=${bindingsList::-1}
emesonargs+=( -D bindings="${bindingsList}" )
local luaChoice=""
- if use lua_targets_luajit; then
+ if use lua_single_target_luajit; then
luaChoice+="luajit"
else
luaChoice+="lua"
@@ -273,16 +286,11 @@ src_configure() {
}
src_compile() {
+ docs_compile
meson_src_compile
-
- if use doc; then
- cd doc/ || die "Failed to switch into doc/ dir."
- doxygen . || die "Doxygen failed to run."
- fi
}
src_install() {
- use doc && local HTML_DOCS=( "${S}"/doc/html/. )
meson_src_install
if use examples; then
diff --git a/dev-libs/efl/efl-1.25.1-r2.ebuild b/dev-libs/efl/efl-1.25.1-r2.ebuild
index f5152f9240ef..0bd9f6753f5c 100644
--- a/dev-libs/efl/efl-1.25.1-r2.ebuild
+++ b/dev-libs/efl/efl-1.25.1-r2.ebuild
@@ -3,7 +3,10 @@
EAPI=7
-inherit meson xdg-utils
+DOCS_BUILDER="doxygen"
+DOCS_DIR="${S}/doc"
+
+inherit docs meson xdg-utils
DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
HOMEPAGE="https://www.enlightenment.org"
@@ -12,7 +15,7 @@ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${P}.tar.xz"
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
-IUSE="+X avif bmp connman cpu_flags_arm_neon dds debug doc drm +eet efl-one elogind examples fbcon
+IUSE="+X avif bmp connman cpu_flags_arm_neon dds debug drm +eet efl-one elogind examples fbcon
+fontconfig fribidi gif gles2-only gnutls glib +gstreamer harfbuzz hyphen ibus ico libressl
lua +luajit jpeg2k json nls mono opengl +pdf physics pmaps postscript psd pulseaudio raw scim
sdl +sound +ssl +svg +system-lz4 systemd tga tgv tiff tslib unwind v4l vnc wayland webp xcf
@@ -89,7 +92,7 @@ RDEPEND="
ibus? ( app-i18n/ibus )
jpeg2k? ( media-libs/openjpeg:= )
json? ( >=media-libs/rlottie-0.0.1_pre20200424:= )
- lua? ( dev-lang/lua:* )
+ lua? ( dev-lang/lua:0= )
luajit? ( dev-lang/luajit:* )
mono? ( dev-lang/mono )
opengl? ( virtual/opengl )
@@ -128,7 +131,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )
nls? ( sys-devel/gettext )"
pkg_setup() {
@@ -145,6 +147,17 @@ src_prepare() {
sed -i "/config_h.set('HAVE_UNWIND/,/eina_ext_deps += unwind/d" src/lib/eina/meson.build ||
die "Failed to remove libunwind dep"
fi
+
+ # Fixup Doxyfile
+ pushd "${DOCS_DIR}" || die
+ cp Doxyfile.in Doxyfile || die
+ sed -i \
+ -e "s/@PACKAGE_VERSION@/${PV}/g" \
+ -e "s/@top_builddir@/../g" \
+ -e "s/@top_srcdir@/../g" \
+ -e "s/@srcdir@/./g" \
+ Doxyfile || die
+ popd || die
}
src_configure() {
@@ -276,16 +289,11 @@ src_configure() {
}
src_compile() {
+ docs_compile
meson_src_compile
-
- if use doc; then
- cd doc/ || die "Failed to switch into doc/ dir."
- doxygen . || die "Doxygen failed to run."
- fi
}
src_install() {
- use doc && local HTML_DOCS=( "${S}"/doc/html/. )
meson_src_install
if use examples; then