summaryrefslogtreecommitdiff
path: root/dev-libs/efl/efl-1.21.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/efl/efl-1.21.1.ebuild')
-rw-r--r--dev-libs/efl/efl-1.21.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/efl/efl-1.21.1.ebuild b/dev-libs/efl/efl-1.21.1.ebuild
index d020ef97f293..c627b1a33b84 100644
--- a/dev-libs/efl/efl-1.21.1.ebuild
+++ b/dev-libs/efl/efl-1.21.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,6 +30,7 @@ REQUIRED_USE="
vnc? ( X fbcon )
wayland? ( egl gles !opengl )
xim? ( X )
+ xpresent? ( X )
"
RDEPEND="
@@ -123,11 +124,11 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXrender
virtual/opengl
- xpresent? ( x11-libs/libXpresent )
)
)
xine? ( media-libs/xine-lib )
xpm? ( x11-libs/libXpm )
+ xpresent? ( x11-libs/libXpresent )
"
DEPEND="
@@ -215,6 +216,7 @@ src_configure() {
$(use_enable xim)
$(use_enable xine)
$(use_enable xpm image-loader-xpm)
+ $(use_enable xpresent)
--with-crypto=$(usex gnutls gnutls $(usex ssl openssl none))
--with-glib=$(usex glib)
@@ -227,7 +229,6 @@ src_configure() {
)
use drm && use wayland && myconf+=( --enable-gl-drm )
- use X && use xpresent && myconf+=( --enable-xpresent )
if use opengl ; then
myconf+=( --with-opengl=full )