summaryrefslogtreecommitdiff
path: root/dev-libs/double-conversion/double-conversion-3.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/double-conversion/double-conversion-3.2.1.ebuild')
-rw-r--r--dev-libs/double-conversion/double-conversion-3.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/double-conversion/double-conversion-3.2.1.ebuild b/dev-libs/double-conversion/double-conversion-3.2.1.ebuild
new file mode 100644
index 000000000000..90995a534fa0
--- /dev/null
+++ b/dev-libs/double-conversion/double-conversion-3.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Binary-decimal and decimal-binary conversion routines for IEEE doubles"
+HOMEPAGE="https://github.com/google/double-conversion"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}