summaryrefslogtreecommitdiff
path: root/dev-libs/cppcodec/cppcodec-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cppcodec/cppcodec-9999.ebuild')
-rw-r--r--dev-libs/cppcodec/cppcodec-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/cppcodec/cppcodec-9999.ebuild b/dev-libs/cppcodec/cppcodec-9999.ebuild
index 3f142b6b6db7..c378468fac29 100644
--- a/dev-libs/cppcodec/cppcodec-9999.ebuild
+++ b/dev-libs/cppcodec/cppcodec-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
HOMEPAGE="https://github.com/tplgy/cppcodec"
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~ppc64 x86"
fi
LICENSE="MIT"
@@ -31,5 +31,5 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}