summaryrefslogtreecommitdiff
path: root/dev-libs/cglm/cglm-0.8.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cglm/cglm-0.8.9.ebuild')
-rw-r--r--dev-libs/cglm/cglm-0.8.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/cglm/cglm-0.8.9.ebuild b/dev-libs/cglm/cglm-0.8.9.ebuild
new file mode 100644
index 000000000000..50287b0bd748
--- /dev/null
+++ b/dev-libs/cglm/cglm-0.8.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit meson
+
+DESCRIPTION="OpenGL Mathematics (glm) for C"
+HOMEPAGE="https://github.com/recp/cglm"
+SRC_URI="https://github.com/recp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ $(meson_use test build_tests)
+ )
+ meson_src_configure
+}