summaryrefslogtreecommitdiff
path: root/dev-libs/castxml/castxml-0.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/castxml/castxml-0.4.5.ebuild')
-rw-r--r--dev-libs/castxml/castxml-0.4.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/castxml/castxml-0.4.5.ebuild b/dev-libs/castxml/castxml-0.4.5.ebuild
new file mode 100644
index 000000000000..35603a9ecafd
--- /dev/null
+++ b/dev-libs/castxml/castxml-0.4.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C-family abstract syntax tree XML output tool"
+HOMEPAGE="https://github.com/CastXML/CastXML"
+SRC_URI="https://github.com/CastXML/CastXML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/CastXML-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-devel/llvm:=
+ sys-devel/clang:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/sphinx
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DCastXML_INSTALL_DOC_DIR="share/doc/${P}"
+ -DCastXML_INSTALL_MAN_DIR="share/man"
+ -DSPHINX_MAN=ON
+ -DSPHINX_HTML=OFF
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}