summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/files/capstone-5.0.2-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capstone/files/capstone-5.0.2-tests.patch')
-rw-r--r--dev-libs/capstone/files/capstone-5.0.2-tests.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-libs/capstone/files/capstone-5.0.2-tests.patch b/dev-libs/capstone/files/capstone-5.0.2-tests.patch
new file mode 100644
index 000000000000..37ec431fb70b
--- /dev/null
+++ b/dev-libs/capstone/files/capstone-5.0.2-tests.patch
@@ -0,0 +1,17 @@
+From b77714b446e93a0ab997b125ef1fb3ad9bc4bb9b Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Wed, 14 Aug 2024 23:28:45 +0200
+Subject: [PATCH] Fix 'make check' for python tests
+Upstream: https://github.com/capstone-engine/capstone/pull/2439
+
+--- a/bindings/python/Makefile
++++ b/bindings/python/Makefile
+@@ -41,7 +41,7 @@ TESTS += test_lite.py test_iter.py test_customized_mnem.py test_alpha.py
+ check:
+ @for t in $(TESTS); do \
+ echo Check $$t ... ; \
+- ./$$t > /dev/null; \
++ ./tests/$$t > /dev/null; \
+ if [ $$? -eq 0 ]; then echo OK; else echo FAILED; exit 1; fi \
+ done
+