summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capstone/capstone-5.0_rc2-r1.ebuild')
-rw-r--r--dev-libs/capstone/capstone-5.0_rc2-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild b/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
index 174d710dac2a..70a870cb34e7 100644
--- a/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
+++ b/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
@@ -4,13 +4,13 @@
EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake distutils-r1 toolchain-funcs
DESCRIPTION="disassembly/disassembler framework + bindings"
HOMEPAGE="http://www.capstone-engine.org/"
-SRC_URI="https://github.com/aquynh/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/capstone-engine/capstone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/5" # libcapstone.so.5
@@ -31,8 +31,10 @@ PATCHES=(
"${FILESDIR}"/${P}-pkgconfig.patch
)
-# Upstream doesn't flag release candidates (bug 858350)
-QA_PKGCONFIG_VERSION=""
+if [[ ${PV} == *_rc* ]]; then
+ # Upstream doesn't flag release candidates (bug 858350)
+ QA_PKGCONFIG_VERSION=""
+fi
wrap_python() {
local phase=$1
@@ -40,10 +42,8 @@ wrap_python() {
if use python; then
pushd bindings/python >/dev/null || die
- echo distutils-r1_${phase} "$@"
- pwd
distutils-r1_${phase} "$@"
- popd >/dev/null
+ popd >/dev/null || die
fi
}