summaryrefslogtreecommitdiff
path: root/dev-libs/c-blosc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/c-blosc')
-rw-r--r--dev-libs/c-blosc/Manifest4
-rw-r--r--dev-libs/c-blosc/c-blosc-1.11.2.ebuild51
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch21
-rw-r--r--dev-libs/c-blosc/metadata.xml23
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/Manifest b/dev-libs/c-blosc/Manifest
new file mode 100644
index 000000000000..98d4faeeac2f
--- /dev/null
+++ b/dev-libs/c-blosc/Manifest
@@ -0,0 +1,4 @@
+AUX c-blosc-1.11.2-fix-build-system.patch 803 BLAKE2B 1472877db42d6a952b8f91a75ba437c6693701cc255a44638c5035d4f723563a5c0dfb5baee73ce0eb061bbaf45c8a49988ba799f35ff3d8b79159e73ea15afe SHA512 3064040af07acc445e4c7a9e962939eafa02d75366e6eee2ce12f15cc5846fbb4214a17d27f9366e8c08b69a3565cb04910008b1e4bd62d6ded3087e1a27124b
+DIST c-blosc-1.11.2.tar.gz 633280 BLAKE2B 426de12ffa0db784fc26316e5758836517f3b3498111cfea64ebd2bc4582ebc6236f64845d41e75db272d3741ab8a7f22a12e0847fb7c98ba10a3ae2c2906e22 SHA512 c1282f60f4ef9d24844be225587e7f46c43ba8a5071f5ee49a7326bce9e84b65312c4f9606e78fd3d1209a4ca50f1c31312a7c377caf9522c9915177c92a4d7b
+EBUILD c-blosc-1.11.2.ebuild 1295 BLAKE2B 6fa832e8eadb8974601885ca87434c0cae161bb7754549a632a654bca7cfa35f69fccf663f40d4f433f06110b95e56ae8c69f78c97809e54eb593be6c7eaffb3 SHA512 cc150fa9fc5f1d0529f09e2e015dde5914a45e5a4e00a6b726ac7b56810b50a8c143e3e2715144ecf58ed82ed21bb738a7fa94ed77d59faa381b3e2413648d37
+MISC metadata.xml 900 BLAKE2B f517d69206738bc44ce57589b720e290fadc3b7e3303cb31782ab8fb6fca859b837716b6ee95a874b22cea713dc7aea436d4a2ec2520f4d5d460f6d6018c2aa0 SHA512 6d6221a4cc1c0f347158f0b2fa729ffb6e87dc720c0a7866529a7120a2b6534daf630f8812b2c5525d7c00646dbe3cfa953257f89330107621c9be08d2c5db0d
diff --git a/dev-libs/c-blosc/c-blosc-1.11.2.ebuild b/dev-libs/c-blosc/c-blosc-1.11.2.ebuild
new file mode 100644
index 000000000000..c06bbca39377
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.11.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0/1"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="cpu_flags_x86_avx2 +lz4 +snappy static-libs test zlib zstd"
+
+RDEPEND="
+ lz4? ( >=app-arch/lz4-1.7.5:= )
+ snappy? ( app-arch/snappy )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.rst RELEASE_NOTES.rst THOUGHTS_FOR_2.0.txt ANNOUNCE.rst )
+PATCHES=( "${FILESDIR}/${PN}-1.11.2-fix-build-system.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # remove bundled libs
+ rm -rf internal-complibs || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_BENCHMARKS=OFF
+ -DDEACTIVATE_AVX2=$(usex !cpu_flags_x86_avx2)
+ -DDEACTIVATE_LZ4=$(usex !lz4)
+ -DDEACTIVATE_SNAPPY=$(usex !snappy)
+ -DDEACTIVATE_ZLIB=$(usex !zlib)
+ -DDEACTIVATE_ZSTD=$(usex !zstd)
+ -DPREFER_EXTERNAL_LZ4=ON
+ -DPREFER_EXTERNAL_SNAPPY=ON
+ -DPREFER_EXTERNAL_ZLIB=ON
+ -DPREFER_EXTERNAL_ZSTD=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
new file mode 100644
index 000000000000..d385d5263710
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
@@ -0,0 +1,21 @@
+Make the build system respect CFLAGS
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,16 +244,6 @@
+ endif()
+
+ # flags
+-# @TODO: set -Wall
+-# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
+-
+-# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
+-# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
+-if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
+- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+-endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+
+ if(MSVC)
+ if(NOT CMAKE_C_FLAGS)
diff --git a/dev-libs/c-blosc/metadata.xml b/dev-libs/c-blosc/metadata.xml
new file mode 100644
index 000000000000..646211224e11
--- /dev/null
+++ b/dev-libs/c-blosc/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Blosc is a compression library designed to transmit data to the
+ processor cache faster than the traditional non-compressed memory fetch.
+ Compression ratios are not very high, but the decompression is very
+ fast. Blosc is meant not only to reduce the size of large datasets on-disk
+ or in-memory, but also to accelerate memory-bound computations.
+ </longdescription>
+ <use>
+ <flag name="lz4">Enable lz4 compression</flag>
+ <flag name="snappy">Enable snappy compression</flag>
+ <flag name="zstd">Enable zstd compression</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Blosc/c-blosc</remote-id>
+ </upstream>
+</pkgmetadata>