summaryrefslogtreecommitdiff
path: root/dev-libs/botan/botan-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan/botan-3.1.0.ebuild')
-rw-r--r--dev-libs/botan/botan-3.1.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-3.1.0.ebuild b/dev-libs/botan/botan-3.1.0.ebuild
index 2fae139bb350..556004d6c660 100644
--- a/dev-libs/botan/botan-3.1.0.ebuild
+++ b/dev-libs/botan/botan-3.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -173,7 +173,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test$(ver_cut 1) || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}
src_install() {